Tags not visible for monitoring on CUWB Server

I am working on a project for indoor localization of an RC car. For this, I will be using the RTLS feature provided by CUWB (Archimedes v2.0). Currently, I have a master and two anchors (will add two more) which I have localized to the ceiling of the room, and I have one tag. When I set them up with serial numbers on the config page of the CUWB server, and look at the RTLS page, the master and anchors are visible on the GUI. However, I am not able to add the Monitor Tag, the drop down for monitoring the Tag is empty.

I have followed the steps in the manual to setup the UWB sensors for RTLS. I do not know as to why the tags are not appearing for selection on the GUI (I have selected the enable tick in the config page).

Server (v2.0)

Any help in setting up the tags will be highly appreciated.

For RTLS mode, you need at least 4 anchors and a master (total of 5) to get your tag’s position

Thank you so much. I have setup 4 anchors with a master now, however I am not able to select the tag in the drop down menu of the GUI. My anchors, master are all grey on the GUI. According to the manual it means they are inactive. Any idea for this cause??

are your anchors and master all connected to the computer running the CUWB server?
can you see the DWUSBs on the DEV tab in the CUWB server?

My DEV page is empty. I have entered all the details of master, anchors and tags in the config page. However, as you mentioned I dont think they are communicating. I have referred to the existing documentation, but i do not find anymore information. Please let me know if there are any available documents.

There’s a few potential causes of your problems:

  1. CUWB v2.0 (Archimedes) only supports DWUSBs. If you’re trying to use DWETHs or DWTAGs, you’ll need to use the CUWB v3.0 (Bernoulli) software.

  2. The master might not be properly connected to the CUWB Server. The master must have a USB or Ethernet connection to the PC that is running the CUWB Server software. Without that, it won’t be able to receive the commands necessary to start up your network, and if the master doesn’t function properly, nothing else will either. As the USB connection is easier to set up, that’s what we would recommend using for a first time install.

  3. The master’s serial port might not be configured properly. To check this, open the Config tab in the CUWB Server application, go to the Serial Ports section, and verify that the master’s serial port is listed in that section. If you don’t know what your master’s serial port is, simply unplug all of your DWUSBs and click the refresh button (green circle of arrows icon) in the Serial Ports section. Then plug in just your master and hit the refresh button again. You should see a serial port pop up in the dropdown box next to the refresh button. Click the “+” button to add that serial port to your configuration.

I have been using DWUSB’s. However, they have DWUSB-SMA 1.0.1 printed on them. However, will they work with the latest server version, which i downloaded from your website a couple of weeks ago?? Could this be the reason for the sensors not to work?

I tried all the suggestions mentioned above, however they do not seem to work.

I solved the issue by performing Firmware update to all the sensors. Thank you for all the suggestions and help.